Phones Pro Issues
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 16:15 PDT
Monitoring
Regarding the recent issues with Phones Pro, our engineers and 3rd party vendor believe that the issue is now resolved and are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Sep 18, 2024 - 15:55 PDT
Update
For inbound calling, a temporary workaround is to enable the Call Continuity feature. This will revert your account to Basic Phones instead of Phones Pro. Inbound calls will be sent to a phone number you define.

When enabling the call continuity feature, the greetings set up in Phones Pro won't be played to callers. The calls won't be distributed to the CSR as they would be with Phones Pro. The number selected to send calls to has to be able to handle an influx of calls.
Posted Sep 18, 2024 - 14:59 PDT
Investigating
We are currently experiencing issues with Phones Pro, so some ServiceTitan users may be encountering issues with inbound and/or outbound calling for Phones Pro. Our engineers are currently investigating the cause along with our 3rd party vendor. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 18, 2024 - 13:51 PDT
This incident affected: Phone Integration (Phones Pro).