Dispatch Pro Issues

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Jan 16, 2024 - 08:20 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2024 - 08:10 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 16, 2024 - 08:04 PST

Investigating

We are currently experiencing issues with Dispatch Pro so some ServiceTitan users may see that their latest runs have failed. Our engineers are currently investigating the cause. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Jan 16, 2024 - 08:00 PST
This incident affected: Product Functionality (Dispatch).