Phones Pro - Inbound Calls not being received

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Jun 06, 2023 - 06:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2023 - 05:50 PDT

Identified

The issue has been identified as problem stemming from our third party vendor. We are awaiting a fix to be implemented.
Posted Jun 06, 2023 - 05:22 PDT

Investigating

We are currently experiencing issues with our Phones Pro phone integration, so some ServiceTitan users may be unable to receive calls. We are currently investigating the cause and scope of this issue. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Jun 06, 2023 - 05:11 PDT
This incident affected: Phone Integration (Phones Pro).