Action Cancelled and Something went wrong error

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Mar 21, 2023 - 08:23 PDT

Monitoring

Regarding the recent issues with error messages prompting while navigating the web application, our engineers believe that they have fixed the underlying cause and are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Mar 21, 2023 - 07:46 PDT
This incident affected: Site Performance (Office).