The issue impacting Fleet Pro has been fully resolved, and all systems are operating normally.
We thank you for your patience and your continued trust in us while we worked to resolve this. If you experience any further issues, please reach out to our Support team and we will be happy to assist!
Posted Sep 08, 2026 - 10:30 PDT
Monitoring
We have deployed a fix for the issue impacting FleetPro and are currently monitoring the system to ensure full recovery.
We greatly appreciate your continued patience & understanding.
Posted Sep 08, 2026 - 10:21 PDT
Identified
We have identified the root cause of the issue impacting FleetPro and are actively implementing a fix. We expect to see recovery shortly.
We greatly appreciate your continued patience & understanding.
Posted Sep 08, 2026 - 10:07 PDT
Investigating
We are actively investigating an issue that may be causing a Service Availability Issue Intermittently . We will provide additional details as we learn more.
We greatly appreciate your patience & understanding as we work towards a resolution.
Posted Sep 08, 2026 - 08:54 PDT
This incident affected: Fleet Pro (Fleet Pro – Application) and Field Pro.