Third Party CDN Issues causing ServiceTitan Performance Issues

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 13:41 PDT

Monitoring

Our third-party provider has implemented a fix and we are monitoring the results.
Posted Sep 02, 2025 - 11:28 PDT

Identified

We’re actively working with our third-party provider to resolve a Content Delivery Network (CDN) issue affecting performance for some users in California, Oregon, and Arkansas. We’ll share another update as soon as we have more information from the provider. Thank you for your patience and understanding.
Posted Sep 02, 2025 - 10:04 PDT
This incident affected: Site Performance (Office).