Our provider is observing expected inbound messaging behavior, and is monitoring for stability. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Sep 10, 2025 - 16:47 PDT
Identified
Our provider has identified the cause and is working on a resolution. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 10, 2025 - 14:43 PDT
Investigating
We are currently experiencing minimal issues with inbound SMS, some ServiceTitan users may not be receiving inbound SMS to local numbers. SMS to toll-free numbers are unaffected. Our SMS provider is currently investigating the cause. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 10, 2025 - 13:32 PDT
This incident affected: Basic Phone Integration (Messaging: SMS Inbound).