Schedule Engine and Contact Center Pro Voice Assistant - Intermittent Slowness

Incident Report for ServiceTitan

Resolved

We have not seen any further issues with Scheduling Pro and the Contact Center Pro Voice Agent and have confirmed the underlying cause to be resolved. We thank you for your patience with this matter. Please reach out to us in Support if you have additional issues and we will be happy to assist!
Posted Nov 18, 2025 - 10:23 PST

Update

Regarding the recent issues with Scheduling Pro and the Contact Center Pro Voice Agent, the necessary actions have been taken, and we believe the underlying cause is resolved. We are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Nov 18, 2025 - 10:00 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 07:35 PST

Investigating

We are Monitoring issues with Scheduling Pro and the Contact Center Pro Voice Agent due to a widespread third-party outage, which may cause some ServiceTitan users to experience intermittent slowness when accessing these resources. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Nov 18, 2025 - 06:01 PST
This incident affected: Schedule Engine and Contact Center Pro (Virtual Voice Agents).