Phones Pro Issues
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 13:43 PDT
Monitoring
Regarding the recent issues with Phones Pro, our engineers believe that the issue is now resolved and are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Sep 18, 2024 - 13:32 PDT
Investigating
We are currently experiencing issues with Phones Pro, so some ServiceTitan users may be encountering issues with inbound and/or outbound calling for Phones Pro. Our engineers are currently investigating the cause along with our 3rd party vendor. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 18, 2024 - 13:16 PDT
This incident affected: Phone Integration (Phones Pro).