Vendor Issue - Phones Pro

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Apr 07, 2023 - 08:47 PDT

Monitoring

Our vendor has confirmed that a fix has been implemented and the results are being monitored.
Posted Apr 07, 2023 - 07:47 PDT

Investigating

We are currently experiencing issues with a third party vendor for our Phones Pro tenants, so some ServiceTitan users may experience issues with logging into the vendor's application. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Apr 07, 2023 - 07:41 PDT
This incident affected: Phone Integration (Phones Pro).