Performance Issues
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 15:12 PDT
Monitoring
Regarding our performance issues, our engineers believe that they have fixed the underlying cause and are currently monitoring for further issues. Thank you for your patience!
Posted Sep 27, 2024 - 14:24 PDT
Investigating
We are currently experiencing some performance issues, so ServiceTitan users may be encountering slowness and/or downtime. Our engineers are currently investigating the cause. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 27, 2024 - 14:01 PDT
This incident affected: Site Performance (Office) and Phone Integration (Basic Phones).