Maps issues in Dispatch with latest version of Chrome

Incident Report for ServiceTitan

Resolved

Maps are now loading properly on all versions of Chrome, including Chrome Version 128. This incident has been resolved.
Posted Aug 24, 2024 - 14:55 PDT

Investigating

We are investigating an issue where customers on Chrome Version 128 are experiencing issues with Maps loading. We advise not updating to the latest version of Chrome until this issue has been resolved.
Posted Aug 23, 2024 - 10:09 PDT
This incident affected: Product Functionality (Dispatch).