ServiceTitan Slowness Issues

Incident Report for ServiceTitan

Resolved

The issue has been resolved, and ServiceTitan system performance has returned to normal levels. All services are operating as expected, and we will continue standard monitoring to ensure continued stability.
Posted Jan 22, 2026 - 07:41 PST

Monitoring

Our engineers have implemented a fix and are continuing to closely monitor the system as performance improves. ServiceTitan users should see ongoing performance improvements. We will provide further updates once the issue is fully resolved.
Posted Jan 22, 2026 - 07:10 PST

Update

We have identified the issue and are observing improvements. ServiceTitan users should now experience enhanced overall performance. We appreciate your understanding!
Posted Jan 22, 2026 - 06:58 PST

Identified

We are currently experiencing slowness with ServiceTitan, so users may be unable to log in. Our engineers have identified the cause and are working on a resolution. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Jan 22, 2026 - 06:34 PST
This incident affected: Site Performance (Office).