Contact Center Pro - Intermittent issues affecting Voice Agent calls

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:08 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:06 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 10:05 PDT

Identified

We are currently experiencing issues with Voice Agent calls within Contact Center Pro stemming from the current issues with AWS. The ServiceTitan team has identified a solution which will be deployed shortly to resume normal operations
Posted Oct 20, 2025 - 09:26 PDT
This incident affected: Contact Center Pro (Virtual Voice Agents).