Inbound SMS - Delays in processing

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 12:45 PDT

Monitoring

Our engineers believe that they have fixed the underlying cause of SMS delays/failures and are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Sep 03, 2025 - 12:14 PDT

Update

We are continuing to investigate this issue.
Posted Sep 03, 2025 - 11:51 PDT

Investigating

We are currently experiencing issues with inbound sms processing, so ServiceTitan users may experience delays in receiving the sms. Our engineers are currently investigating the cause. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Sep 03, 2025 - 08:03 PDT
This incident affected: Basic Phone Integration (Messaging: SMS Inbound).