Outbound Calls: Downstream Provider Service Availability Issue

Incident Report for ServiceTitan

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 04:25 PDT

Monitoring

Our 3rd party provider has deployed a fix for the issue impacting outbound calls, and we are seeing services recovering. We are actively monitoring the situation to ensure full stability.

Thank you for your understanding & support.
Posted Aug 10, 2026 - 21:10 PDT

Investigating

We are actively investigating an issue with a 3rd party service provider that may be causing a service interruption. We will provide additional details as we learn more.

We greatly appreciate your patience & understanding as we work with our partner towards a resolution.
Posted Aug 10, 2026 - 20:38 PDT
This incident affected: Phones Pro (Telephony Platform: Outbound Calling) and Contact Center Pro (Telephony Platform: Outbound Calling).