Contact Center Pro - 3rd Party Service Availability Issue

Incident Report for ServiceTitan

Resolved

The issue impacting Contact Center Pro has been fully resolved by our 3rd party provider, and all systems are operating normally.

We thank you for your patience and your continued trust in us while we worked with our partner to resolve this. If you experience any further issues, please reach out to our Support team and we will be happy to assist!
Posted Apr 17, 2026 - 13:21 PDT

Monitoring

Our 3rd party provider has deployed a fix for the issue impacting Contact Center Pro, and we are seeing services begin to recover. If you are still experiencing issues, please click Reset and refresh your page. We are actively monitoring the situation to ensure full stability.

Thank you for your understanding & support.
Posted Apr 17, 2026 - 13:06 PDT

Investigating

We are actively investigating an issue with a 3rd party service provider that may be causing a service interruption for some of our users. We will provide additional details as we learn more.

We greatly appreciate your patience & understanding as we work with our partner towards a resolution.
Posted Apr 17, 2026 - 12:53 PDT
This incident affected: Contact Center Pro (Telephony Platform: Inbound Calling).